Ticket #682 (closed assessed: fixed)

Opened 8 years ago

Last modified 8 years ago

Ecopath Detritus Fate values disappear

Reported by: stevem Owned by: jeroens
Priority: high Milestone: Ecopath 6: release 6.0.8
Component: Ecopath Version:
Severity: major Keywords: Ecopath, detritus fate
Cc:

Description

To reproduce:

  • Import old database. Conversion OK
  • Go to detritus fate and check groups – OK
  • Go to parameterisation and hit basic estimates – error DF message
  • Check DF screen – missing values for groups 50-54

Change History

comment:1 Changed 8 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

DF values are rejected due to a rigorous "sum > 1" test, combined with slight rounding errors when the application runs stand-alone. These errors do not seem to occur when running the software in the debug environment!

The issue was solved by making the comparison rounded on the 4th decimal point, thus introducing a slight grace margin.

Note: See TracTickets for help on using tickets.