Ticket #719 (closed assessed: fixed)

Opened 9 years ago

Last modified 9 years ago

MSE plots crashes when closed

Reported by: joeb Owned by: jeroens
Priority: urgent Milestone: Ecopath 6: release 6.0.8
Component: MSE Version:
Severity: crash Keywords:
Cc:

Description

Run the MSE and open the MSE Plots from.

Close the MSE Plots from. OnFormClosed? will throw an unhandled exception me.UIContext is nothing

Change History

comment:1 Changed 9 years ago by jeroens

  • Priority changed from normal to urgent
  • Status changed from new to closed
  • Type changed from NOT SET to assessed
  • Resolution set to fixed
  • Milestone changed from NOT SET to Ecopath 6: build 6.0.8

This is caused by frmEwE releasing the UI context in OnFormClosed?. As a consequence, every form needs to clean up first before invoking mybase.OnFormClosed?

Note: See TracTickets for help on using tickets.