Ticket #72 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Ecosim Biomass output

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

When I run a model, it appears that the biomass is increasing from 0.25 to 1 in the first year. Why is this not starting at 1 already? I think it should be at one- unless I am missing something? (using lab 1 model)

So I reopened the Tampa Bay model, to see if the same trend occured- this jump at the begining to get the biomass at one rather than starting at one, but I loaded the scenario and Ecosim wouldnt run. All the buttons look like they are working, but I am not getting the display of biomass, and i am not sure the reason or what I have done. So I closed the model and the program and tried again, and now it all works again. maybe i just opened and closed too many models in a row?

But because the time frame of the model is set to 51 years, I cannot tell.

Change History

comment:1 Changed 11 years ago by shermanl

SL: Carrie, we discussed this problem. None of us could reproduce this. We suspect that the model dies so quickly in the first time step that it appears to start at 0.25. We know computationally that starting from 0.25 is impossible.

If you suspect it does NOT die in the first timestep, come see us and show us the bugs.

comment:2 Changed 11 years ago by carieh

Ok, I will have a look again when I get to more serious Ecosim testing. I think there will be more changes before I get to re-testing this.

comment:3 Changed 11 years ago by carieh

Ecosim- run biomass- I am still getting this increase in biomass at the beginning. Why is it not starting from 1? I have exaggerated it here so you can see it. , ideally it should be a smooth line from the first time step.

Please see doc july1.doc for the screen images, then I think it will be clearer.

comment:4 Changed 11 years ago by shermanl

Fang, could you look into this issue by outputing all the numbers you get from the core. It does seem it does start from lower than 1 in the initial timestep plotted. See her document she attached.

comment:5 Changed 11 years ago by joeb

Fang, I'm pretty sure this is a drawing issue. Ecosim calls the TimeStepDelegate? passed in via cCore.RunEcosim?(TimeStepDelegateToCall?) at the end of the first time step. cEcoSimResults.Biomass() will equal [biomass from first timestep] / [start biomass] this will not be zero. The drawing routine must have to start from some place so it probably starts at zero and draws a line to the first result. The .25 is just what it looks like not the actual value.

comment:6 Changed 11 years ago by jeroens

De-assigned

comment:7 Changed 11 years ago by shermanl

Bug fix - drawing starts with 0 changed to 1 the very start of EcoLineGraph? bug#74.
Still requires core to supply 1 at TS 0

Note: See TracTickets for help on using tickets.