Ticket #737 (closed assessed: fixed)

Opened 8 years ago

Last modified 8 years ago

Ecosim Fishing Mort timeseries and sketched effort

Reported by: joeb Owned by:
Priority: normal Milestone: Ecopath 6: release 6.1.1
Component: Ecosim Version:
Severity: major Keywords:
Cc:

Description (last modified by jeroens) (diff)

When Fishing mortality timeseries (type 4) are loaded it overwrites the fishing mortality that is caused by effort sketched by a user in the effort form. This is working and is consistent with EwE5. However, when F timeseries are loaded and different efforts are sketched in after the load, there can be a slight difference in the Ecosm run results. In this case there should be no difference between runs. Mortality should, and does, come from the timeseries. It appears that fishing mortality is coming from the timeseries, as it should, but the sketched effort is having an effect on some other variable that is affecting the run. Both EwE5 and EwE6 do this, at least they are consistent.

One possible source for this kind of a problem would be detritus from discards, as this is calculated from the sketched effort. However, this is not the case in the model I used because it has no discards....

To recreated this create a timeseries for fishing mortality and load it into a model. Turn on the overlays and run Ecosim. Sketch in some major change in effort and re-run Ecosim you should see slight differences between the runs.

Change History

comment:1 Changed 8 years ago by brianl

Joe, I'm having the same issue with the newest public version 6.0.7.114. Although my F time series remains the same (as does biomass), I can drop all effort to 0 which causes catch to decline to 0 too. When there are multiple gears, and I drop effort to 0 for one of them, the catch moves over to the other gear.

comment:2 Changed 8 years ago by jeroens

  • Type changed from NOT SET to assessed
  • Milestone changed from NOT SET to Ecopath 6: build 6.1.1

comment:3 Changed 8 years ago by jeroens

  • Description modified (diff)

comment:4 Changed 8 years ago by joeb

  • Status changed from new to closed
  • Resolution set to fixed

cFishingRateShape.Update() was updating the fishing mortality in response to an edit even if fishing mortality time series was loaded. I have changed this so that "F" is no longer editable when "F" time series is loaded.

Note: See TracTickets for help on using tickets.