Ticket #83 (closed: fixed)

Opened 12 years ago

Last modified 11 years ago

Edit fleets Errors

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

Very similar errors to the inputing data ones. I think they are de-bugging messages, and I get a large pop-up window with them. I just click ignore and they seem to go away.
The error reads- Database corrupted on DCI input (2,3)=0.607, expected 0. I get it every time I edit the fleets, hopefully it makes sense to someone.

I have added in 5 fleets (and named them)- The default values are correct, with the exception of one- either the first or second group I have added in. I'm not sure- so will try again.
I deleated the fleets (all of them) and I get more pop-up error messages. not just the warnings to delete fleets, but actual messages I need to ignore. After all of my fleets are deleated, I am left with fleet 1 the default fleet, and the default values for effort related cost, sailing, and profit are not correct. I am getting 100% for cost, and 0% for the other two.

So I re-inputed the fleets and now they all have correct values for %'s. I am going to try again with another model to see if I can reproduce.
But when I delete them, the default goes to the INcorrect values again???

Attempt 2. . . . where do the values go wrong?
So with a new model, the default fleet fleet1 has an incorrect value under definition of fleets. I think if you open a new model and go into this tab, you will see the default values are off. When I add in 2 fleets this time, the one that was originally fleet1 still has the incorrect default values, while the second has the correct values.

I deleted them both, got a lot of error messages, which I ignored, then re-created the 2 fleets. Once I re-create the two fleets, both have CORRECT default values. I am thinking you need to delete the original default fleet- and then all subsequent fleets added in will have the correct default values. This is probably an issue with only the default, which is likely why it was missed.... nobody likes to make models (except me)

Definite solution: user can erase all fleets and recreate. Only Ecospace seems to have issues when running w/o fleets. The rest of the app seems to behave wonderfully well.

Change History

comment:1 Changed 11 years ago by jeroens

I am able to recreate this panic when adding fleets to a new and empty model. Is that what you were doing, Carie?

The one default fleet does not really exist but is created in-memory, not in the database, when a new model is created. By adding the default fleet to the empty database that is used for new models this problem is circumvented. Kewl.

However...

The edit fleet dialog still allows the user to destroy all fleets, which will happily create chaos. The best solution is to make the GUI prevent the user from deleting any last remaining fleet.

Note: See TracTickets for help on using tickets.