Ticket #872 (closed assessed: fixed)

Opened 8 years ago

Last modified 8 years ago

Ecospace crashes when changing Ecosim Scenarios from the Advection form

Reported by: joeb Owned by: jeroens
Priority: low Milestone: Ecopath 6: release 6.2
Component: Ecospace Version:
Severity: crash Keywords:
Cc:

Description

When the Advection and Run Ecospace forms are open RunEcospace? will crash if a new Ecosim Scenario is loaded

  • Open the Advection form first, this will prompt for Sim and Space scenarios.
  • Open the Run Ecospace form.
  • Switch back to the Advection form.
  • Open a new Ecosim scenario from the Advection form without closing any of the forms.
  • RunEcospace?.pbColors_Paint() should throw an exception

This is supper finicky to reproduce, so not a huge priority. If you do any of these steps out of order the Exception does not happen... 

Change History

comment:1 Changed 8 years ago by jeroens

  • Owner set to jeroens
  • Status changed from new to assigned

comment:2 Changed 8 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution set to fixed

The error is more complicated, and derives from a ScInt framework order issue. Changing Ecosim scenarios while two or more Ecospace forms are visible will correctly cause the first Ecospace form to close, giving the second Ecospace form focus, which in turn will attempt to restore the core status to 'Ecospace'. This leads to confusion and may have a series of unpredictable results.

The solution is to disable any core state synchronization while responding to a core state change. Since this is purely a UI issue, this bug is fixed in the UI by temporarily disabling the core controller while responding to a core state change.

Note: See TracTickets for help on using tickets.