Ticket #92 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

importing a model- producer/consumer groups switching

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

importing a model-works fine- all the groups remain in their correct places

phytoplankton groups are being switched to consumers in basic input, and group 5 in lab 1- norway pout, is getting switched to producer when you open the model.
In the newest version (released June 15th) I am not seeing the 5th group getting switched to a producer, but producer groups are being switched to consumers.

THIS ONLY HAPPENS WITH CREATED MODELS, NOT IMPORTED ONES.
Models tested: Lab 1 Norway Pout June 6 (bug occurs every time model is re-opened)

Lab 1 norway pout June 14th- (bug occurs- AND group 2 (consumer) gets switched to a producer (every time the model is re-opened)- I also get quite a lot of errors trying to open this model.

Lab 1 Norway Pout May 23- (same issues as june 14 issue)- group 2 is also being switched to a producer, and phytoplankton (group5)is getting switched to a consumer. Also with this model I am getting the errors opening it.

all models are available in ftp folder

Change History

comment:1 Changed 11 years ago by administrator

related to #90

comment:2 Changed 11 years ago by jeroens

When creating a model, changes in the consumer/producer/detritus role of an existing group would not be saved to the database. This has been fixed.

comment:3 Changed 11 years ago by jeroens

Failure of producer/consumer/detritus values to make it to the database caused incorrect shading in bug 92

Note: See TracTickets for help on using tickets.