Ticket #966 (closed assessed: fixed)

Opened 7 years ago

Last modified 7 years ago

Detritus flags are incorrectly cleared

Reported by: villyc Owned by: jeroens
Priority: normal Milestone: Ecopath 6: release 6.2
Component: Ecopath Version:
Severity: minor Keywords:
Cc:

Description

To reproduce:

  • Load a model with more than one detritus group
  • Enter a sum of detritus values > 1 for a group
  • Run Ecopath

A message will pop up informing the user of the incorrect values. In the detritus fate grid however the wrong values are cleared. Any newly entered values do not show up

The values should not be cleared.

Change History

comment:1 Changed 7 years ago by jeroens

The issue is made worse by the fact that newly entered detritus fate flags are stored in the Core, but are not visible. This in turn affects the respiration calculations.

comment:2 Changed 7 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

The issue is fixed in cCore; detritus fate values are no longer cleared

Note: See TracTickets for help on using tickets.