Ticket #977 (closed not assessed: not an issue)

Opened 8 years ago

Last modified 8 years ago

Exception on time series weights

Reported by: villyc Owned by: jeroens
Priority: high Milestone: Ecopath 6: release 6.2
Component: User Interface Version:
Severity: major Keywords:
Cc:

Description

Dear Villy,

everytime I try to change the time series weights in the EwE 6 (latest
version) I got an error message. Not sure if something wrong in my
model/computer.
see below:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

Exception Text
System.NullReferenceException?: Object reference not set to an instance of an
object.

at ScientificInterface?.gridWeightTS.Apply(Boolean bEnableAll)
at ScientificInterface?.dlgManageTimeSeries.OnOK(Object sender, EventArgs?

e)

at System.Windows.Forms.Control.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.PerformClick?()
at System.Windows.Forms.Form.ProcessDialogKey?(Keys keyData)
at System.Windows.Forms.Control.ProcessDialogKey?(Keys keyData)
at System.Windows.Forms.Control.ProcessDialogKey?(Keys keyData)
at System.Windows.Forms.Control.ProcessDialogKey?(Keys keyData)
at System.Windows.Forms.ContainerControl?.ProcessDialogKey?(Keys keyData)
at System.Windows.Forms.Control.PreProcessMessage?(Message& msg)
at System.Windows.Forms.Control.PreProcessControlMessageInternal?(Control

target, Message& msg)

at

System.Windows.Forms.Application.ThreadContext?.PreTranslateMessage?(MSG& msg)


Loaded Assemblies
mscorlib

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1882 (QFEN-1.050727-1800)
CodeBase?:

file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll


EwE6

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwE6.exe


Microsoft.VisualBasic?

Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f
11d50a3a/Microsoft.VisualBasic?.dll


System

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System
.dll


System.Windows.Forms

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561
934e089/System.Windows.Forms.dll


System.Drawing

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3
a/System.Drawing.dll


System.Runtime.Remoting

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c
561934e089/System.Runtime.Remoting.dll


ScientificInterfaceShared?

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/ScientificInterfaceSh
ared.DLL


EwECore

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwECore.DLL


EwEUtils

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwEUtils.DLL


EwEPlugin

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwEPlugin.DLL


WeifenLuo?.WinFormsUI.Docking

Assembly Version: 2.3.3729.14004
Win32 Version: 2.3.0.0
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/WeifenLuo.WinFormsUI.
Docking.DLL


SourceGrid2

Assembly Version: 2.0.3.1
Win32 Version: 2.0.3.1
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/SourceGrid2.DLL


System.Configuration

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f1
1d50a3a/System.Configuration.dll


System.Xml

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/Sy
stem.Xml.dll


sfpu2pdv

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System
.dll


SAUPUtil

Assembly Version: 6.0.4.4
Win32 Version: 6.0.4.4
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/SAUPUtil.DLL


System.Data

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/Sys
tem.Data.dll


EwEFlowDiagramPlugin

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwEFlowDiagramPlugin.
DLL


EwENetworkAnalysis

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwENetworkAnalysis.DL
L


ZedGraph?

Assembly Version: 5.1.4.17508
Win32 Version: 5.1.4.17508
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/ZedGraph.DLL


System.Web.Services

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Web.Services/2.0.0.0__b03f5f7f11
d50a3a/System.Web.Services.dll


EwEResultsExtractorPlugin

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwEResultsExtractorPl
ugin.DLL


EwEValueChainPlugin

Assembly Version: 6.1.1.1109
Win32 Version: 6.1.1.1109
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/EwEValueChainPlugin.D
LL


SourceLibrary?

Assembly Version: 1.2.0.0
Win32 Version: 1.2.0.0
CodeBase?:

file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206/SourceLibrary.DLL


kpk1ar58

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System
.dll


System.Transactions

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_32/System.Transactions/2.0.0.0__b77a5c561934
e089/System.Transactions.dll


System.EnterpriseServices?

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_32/System.EnterpriseServices/2.0.0.0__b03f5f
7f11d50a3a/System.EnterpriseServices?.dll


System.Core

Assembly Version: 3.5.0.0
Win32 Version: 3.5.21022.8 built by: RTM
CodeBase?:

file:///C:/WINDOWS/assembly/GAC_MSIL/System.Core/3.5.0.0__b77a5c561934e089/S
ystem.Core.dll



JIT Debugging
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Change History

comment:1 Changed 8 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to not an issue

Tested and confirmed w user: the bug was solved along the way since the last release. No longer an issue in 6.2 beta

Note: See TracTickets for help on using tickets.