Ticket #994 (closed assessed: fixed)

Opened 8 years ago

Last modified 8 years ago

Cannot Delete Groups in Ecopath 6.2 beta

Reported by: keithhg Owned by:
Priority: high Milestone: Ecopath 6: release 6.2
Component: Ecopath Version:
Severity: crash Keywords:
Cc: Keith.Hayse-Gregson@…

Description

I am trying to delete a group in Ecopath 6.2 beta, when I click OK the group does not delete and then windows gives me a warning and the program crashes.

Not sure what is going on.

Below are the details of the Windows warning::::

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

Exception Text
System.NullReferenceException?: Object reference not set to an instance of an object.

at EwECore.cCoreInputOutputBase.get_Index()
at EwECore.cStanzaGroup.get_NStanzas()
at ScientificInterface?.gridDefineGroups.Apply()
at ScientificInterface?.Ecopath.EditGroups?.OK_Button_Click(Object sender, EventArgs? e)
at System.Windows.Forms.Control.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.OnMouseUp?(MouseEventArgs? mevent)
at System.Windows.Forms.Control.WmMouseUp?(Message& m, MouseButtons? button, Int32 clicks)
at System.Windows.Forms.Control.WndProc?(Message& m)
at System.Windows.Forms.ButtonBase?.WndProc?(Message& m)
at System.Windows.Forms.Button.WndProc?(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow?.OnMessage?(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow?.WndProc?(Message& m)
at System.Windows.Forms.NativeWindow?.Callback(IntPtr? hWnd, Int32 msg, IntPtr? wparam, IntPtr? lparam)

Loaded Assemblies
mscorlib

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3620 (GDR.050727-3600)
CodeBase?: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll


EwE6

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwE6.exe


Microsoft.VisualBasic?

Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll


System

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3614 (GDR.050727-3600)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


System.Windows.Forms

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


System.Drawing

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


System.Runtime.Remoting

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll


ScientificInterfaceShared?

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/ScientificInterfaceShared.DLL


EwECore

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwECore.DLL


EwEUtils

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwEUtils.DLL


EwEPlugin

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwEPlugin.DLL


WeifenLuo?.WinFormsUI.Docking

Assembly Version: 2.3.3729.14004
Win32 Version: 2.3.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/WeifenLuo.WinFormsUI.Docking.DLL


SourceGrid2

Assembly Version: 2.0.3.1
Win32 Version: 2.0.3.1
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/SourceGrid2.DLL


System.Configuration

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll


System.Xml

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll


_avp9fad

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3614 (GDR.050727-3600)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


SAUPUtil

Assembly Version: 6.0.4.4
Win32 Version: 6.0.4.4
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/SAUPUtil.DLL


System.Data

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll


EwEFlowDiagramPlugin

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwEFlowDiagramPlugin.DLL


EwENetworkAnalysis

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwENetworkAnalysis.DLL


ZedGraph?

Assembly Version: 5.1.4.17508
Win32 Version: 5.1.4.17508
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/ZedGraph.DLL


System.Web.Services

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Web.Services/2.0.0.0__b03f5f7f11d50a3a/System.Web.Services.dll


EwEResultsExtractorPlugin

Assembly Version: 6.2.0.518
Win32 Version: 6.2.0.0518
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/EwEResultsExtractorPlugin.DLL


SourceLibrary?

Assembly Version: 1.2.0.0
Win32 Version: 1.2.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206%20BETA/SourceLibrary.DLL


axvgq9pv

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3614 (GDR.050727-3600)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


System.Web

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3618 (GDR.050727-3600)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.Web/2.0.0.0__b03f5f7f11d50a3a/System.Web.dll


Microsoft.mshtml

Assembly Version: 7.0.3300.0
Win32 Version: 7.0.3300.0
CodeBase?: file:///C:/WINDOWS/assembly/GAC/Microsoft.mshtml/7.0.3300.0__b03f5f7f11d50a3a/Microsoft.mshtml.dll


System.Transactions

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.Transactions/2.0.0.0__b77a5c561934e089/System.Transactions.dll


System.EnterpriseServices?

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.EnterpriseServices/2.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll


System.Deployment

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll


JIT Debugging
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Change History

comment:1 Changed 8 years ago by keithhg

  • Severity changed from NOT SET to crash
  • Cc Keith.Hayse-Gregson@… added
  • Component changed from NOT SET to Ecopath
  • Summary changed from Cannot Delete Groups 6.2 beta to Cannot Delete Groups in Ecopath 6.2 beta
  • Priority changed from NOT SET to normal
  • Milestone set to Ecopath 6: release 6.2

comment:2 Changed 8 years ago by jeroens

  • Priority changed from normal to high
  • Type changed from NOT SET to assessed

Hi Keith,
Drat, you're totally right. We're on it, thanks for this.

comment:3 Changed 8 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

Fixed, bug was caused by a malformed database foreign key constraint

Note: See TracTickets for help on using tickets.